Welcome
Welcome to refracta

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

Boot failure + older snapshot versions (util-linux >=2.25)

Stuff that has not yet gone into the official build.

Boot failure + older snapshot versions (util-linux >=2.25)

Postby dzz » Mon May 16, 2016 11:52 am

Older versions of snapshot did not boot Jessie properly with util-linux >=2.25.

Following on from going-with-the-systemd-flow-or-not-t422-90.html (That thread got fragmented and the problem seems not to do with systemd):

We found two workarounds. Patch /usr/share/initramfs-tools/init OR use a minimal fixed /dev (like live-build does). We could see what was happening but never actually nailed down the cause. Now:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=823856
https://bugs.debian.org/cgi-bin/bugrepo ... bug=823069

New live-boot just got into unstable. I rebuilt an old snapshot with an empty /dev which would not boot, using a live initrd patched with files from live-boot and live-boot-initramfs-tools _1:20160511 .. Now it boots.

The updated patch I used (originally designed to enable RW mount of the live-media partition): http://exegnulinux.net/refracta/experim ... 511.tar.gz

Interestingly the recent devuan-minimal ISO from KatolaZ does boot with original initramfs-tools/init and empty /dev (probably because, such a minimal service init setup does not have to wait for udev)
dzz
 
Posts: 647
Joined: Wed Apr 27, 2011 11:53 am
Location: Devon, England

Return to Experimental

Who is online

Users browsing this forum: No registered users and 0 guests

cron
suspicion-preferred