Welcome
Welcome to refracta

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

[SOLVED] Realtek LAN / rtl8168e-e3.fw not working

Ask your questions here.

[SOLVED] Realtek LAN / rtl8168e-e3.fw not working

Postby jotka » Thu Mar 23, 2017 8:31 am

This is what I did:

- boot Life-CD (8.3)
- "dpkg -i realtek-firmware..." (needed one is definitely rtl8168e-e3.fw, working in Debian!)
- install to hard disk

In the bootlog the firmware was correctly loaded and sometimes the system got an IP, but no "real" connection is established. I tried this over and over again, with and without editing ".../interfaces" and like. There's some kind of connection I think, but not really functional ... ? ... :(

Perhaps anything else is needed? Module (r8169) seems normally loaded...

Thanks for help
jotka
Last edited by jotka on Thu Mar 23, 2017 4:17 pm, edited 1 time in total.
jotka
 
Posts: 3
Joined: Thu Mar 23, 2017 8:19 am

Re: Realtek LAN / rtl8168e-e3.fw not working

Postby FOSSuser » Thu Mar 23, 2017 8:58 am

If I'm not mistaken, firmware is loaded at boot time, therefore, if it is not included in a live distro, it cannot be loaded when running live session.

If you have installed, check out which modules are being loaded, use lsmod in a terminal & see if the modules show up.
Last edited by FOSSuser on Thu Mar 23, 2017 9:03 am, edited 2 times in total.
FOSSuser
 
Posts: 29
Joined: Mon Dec 05, 2016 7:19 pm

Re: Realtek LAN / rtl8168e-e3.fw not working

Postby jotka » Thu Mar 23, 2017 8:59 am

Perhaps I found a solution. Debian uses the r8169 module but that's known to not work well.
Better is using the r8168-dkms from non-free (not in stable...). Let's see
jotka
 
Posts: 3
Joined: Thu Mar 23, 2017 8:19 am

Re: Realtek LAN / rtl8168e-e3.fw not working

Postby dzz » Thu Mar 23, 2017 12:36 pm

dzz
 
Posts: 647
Joined: Wed Apr 27, 2011 11:53 am
Location: Devon, England

Re: Realtek LAN / rtl8168e-e3.fw not working

Postby jotka » Thu Mar 23, 2017 3:15 pm

It's working! It's that easy... To shorten the whole thing: Because of r8168 being closed source it's not used in Debian/Devuan. The (free) r8169 is used instead, but that's not working in every case. r8168 is in testing / non-free. So here's what did the job:

- download the "r8168-dkms" deb-file directly
- boot Refracta
- install to harddisk
- boot installed system
- dpkg -i "r8168-dkms...deb" (no dependencies)
- dpkg -i "realtek-firmware...deb"
- reboot

Thanks and bye! jotka
jotka
 
Posts: 3
Joined: Thu Mar 23, 2017 8:19 am


Return to Help

Who is online

Users browsing this forum: No registered users and 0 guests

cron
suspicion-preferred