Welcome
Welcome to refracta

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

UEFI-awareness

Stuff that has not yet gone into the official build.

UEFI-awareness

Postby miraculix » Sat Jan 17, 2015 5:42 pm

Dear Ladies and Gentlemen!

I've patched versions 9.1.2 of refractasnapshot and -gui to be able to start on modern UEFI-hardware successfully. Please return to me with an email-address to which I can send modified and newly requested files.

Kind Regards
Peter
miraculix
 
Posts: 13
Joined: Sun Oct 05, 2014 7:02 pm

Re: UEFI-awareness

Postby fsmithred » Sat Jan 17, 2015 7:44 pm

Thanks! I don't have the proper hardware to test uefi. See your inbox (or get my address from the head of the script.)
User avatar
fsmithred
 
Posts: 2089
Joined: Wed Mar 09, 2011 9:13 pm

Re: UEFI-awareness

Postby fsmithred » Mon Jan 26, 2015 9:23 pm

I'm working on this. Also adding some other stuff. Will have beta debs ready soon.
User avatar
fsmithred
 
Posts: 2089
Joined: Wed Mar 09, 2011 9:13 pm

Re: UEFI-awareness

Postby fsmithred » Tue Jan 27, 2015 1:14 am

https://sourceforge.net/projects/refrac ... s/testing/
refractasnapshot gui and base, 9.1.5+10.0.0~beta01 debs are uploaded. Please test with amd64 jessie and uefi bios.

I made a snapshot in 32-bit jessie-sysv, and it looks like I didn't break anything. Also added code to patch /usr/share/initramfs-tools/init if systemd is not installed and util-linux version is 2.25. That works.
User avatar
fsmithred
 
Posts: 2089
Joined: Wed Mar 09, 2011 9:13 pm

Re: UEFI-awareness

Postby fsmithred » Tue Feb 03, 2015 8:10 pm

refractasnapshot gui and base, 9.1.5+10.0.0~beta02 debs are up, same place.

Fixed dependencies so it installs on wheezy.
Moved $uefi_opt to last option in xorriso, so iso boots on uefi hardware.
User avatar
fsmithred
 
Posts: 2089
Joined: Wed Mar 09, 2011 9:13 pm


Return to Experimental

Who is online

Users browsing this forum: No registered users and 1 guest

suspicion-preferred